为编程爱好者分享易语言教程源码的资源网
好用的代理IP,游戏必备 ____广告位招租____ 服务器99/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器
好用的代理IP,游戏必备 ____广告位招租____ 服务器低至38/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器

网站首页 > 易语言相关 > 易语言例程 正文

自动调整超级列表框的列宽源码

三叶资源网 2023-02-25 20:43:25 易语言例程 803 ℃ 0 评论

菜鸟一枚,琢磨一下怎么样随文本长度(包括列标题)自动调整超级列表框的列宽,论坛应该已经有类似的了,相互学习哈。大神们可以忽略啦~~~~~~

.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕



.子程序 _按钮1_被单击
.局部变量 a, 整数型
.局部变量 i, 整数型
.局部变量 w, 整数型

w = 到整数 (编辑框1.内容)
.计次循环首 (w, i)
    a = 超级列表框1.插入表项 (, , , , , )
    超级列表框1.置标题 (a, 0, “第” + 到文本 (i) + “款式”)
    超级列表框1.置标题 (a, 1, “+” + 到文本 (i) + “码”)
    超级列表框1.置标题 (a, 2, 到文本 (i × 100) + “套”)
.计次循环尾 ()

.子程序 _按钮2_被单击
.局部变量 i, 整数型
.局部变量 j, 整数型
.局部变量 文长, 整数型
.局部变量 文长组, 整数型, , "0"

.如果 (超级列表框1.取表项数 () ≠ 0)
    .计次循环首 (超级列表框1.取列数 (), i)
        .计次循环首 (超级列表框1.取表项数 (), j)
            文长 = 取文本长度 (超级列表框1.取标题 (j - 1, i - 1))
            加入成员 (文长组, 文长)
        .计次循环尾 ()
        数组排序 (文长组, 假)  ' 排序后,最大值为:文长组[1],即列中最长文本的长度
        .判断开始 (取文本长度 (超级列表框1.取列标题 (i - 1)) < 文长组 [1])
            超级列表框1.置列宽 (i - 1, -1)  ' -1 ,则根据【列数据】最大宽度自动调整列尺寸
        .判断 (取文本长度 (超级列表框1.取列标题 (i - 1)) ≥ 文长组 [1])
            超级列表框1.置列宽 (i - 1, -2)  ' -2 ,则根据【列标题】宽度自动调整列尺寸
        .默认

        .判断结束
        清除数组 (文长组)
    .计次循环尾 ()
.否则

.如果结束


.子程序 _编辑框1_内容被改变

超级列表框1.全部删除 ()
超级列表框1.置列宽 (0, 50)
超级列表框1.置列宽 (1, 50)
超级列表框1.置列宽 (2, 50)

.子程序 _编辑框1_获得焦点

编辑框1.内容 = “”

.子程序 _按钮3_被单击

超级列表框1.全部删除 ()
_按钮1_被单击 ()
_按钮2_被单击 ()

@碎石

文件下载


来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网⑤群:21414575

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网⑤群:三叶资源网⑤群

网站分类
随机tag
QQ群引流jar打包多线程模板设置系统捕获网卡GIF录屏KMP算法抗锯齿PDO数据WEBQQ登录读写IE浏览器彩虹秒赞网数组去重复新浪博客群号转链接复制组件VTCP觅风易语言教程线程池快手did获取
最新评论