为编程爱好者分享易语言教程源码的资源网
好用的代理IP,游戏必备 ____广告位招租____ 服务器99/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器
好用的代理IP,游戏必备 ____广告位招租____ 服务器低至38/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器

网站首页 > 易语言相关 正文

微博发博发帖例子

三叶资源网 2024-03-17 21:00:03 易语言相关 582 ℃ 2 评论

.版本 2

.支持库 spec

.支持库 eAPI


.程序集 窗口程序集_启动窗口


.子程序 __启动窗口_创建完毕




.子程序 发微博, 逻辑型, 公开, 发布成功返回真 随机301种手机类型

.参数 cookie, 文本型

.参数 pid, 文本型, 可空, 多张图片用,分隔 例如 pid1,pid2

.参数 内容, 文本型

.参数 backdata, 文本型, 可空

.局部变量 temp, 文本型

.局部变量 i, 整数型

.局部变量 类型, 文本型

.局部变量 类型数组, 文本型, , "0"

.局部变量 帖子链接, 文本型

.局部变量 来源, 文本型


temp = 编码_usc2到ansi (编码_URL解码_快速 (到文本 (网页_访问_对象 (“https://widget.weibo.com/public/aj_addMblog.php”, 1, “content=” + 编码_URL编码 (内容, , 真) + “&appkey=&style_type=1&pic_id=” + pid + “&refer=&return_type=2&vsrc=base_topic&wsrc=app_topic_base&ext=&html_type=2&_t=0&app_src=2ue2lQ”, cookie, , “x-requested-with: XMLHttpRequest”, , , , , , , , , , , , , )), 真, ))

' 置剪辑板文本 (temp)

' 调试输出 (temp)

.如果真 (倒找文本 (temp, “系统繁忙,请稍后再试!”, , 假) ≠ -1)

    backdata = “系统繁忙”

    异常 = “系统繁忙”

    ' 编辑框3.内容 = “系统繁忙,请稍后再试!”

    返回 (假)

.如果真结束

.如果真 (倒找文本 (temp, “未登录”, , 假) ≠ -1)

    backdata = “未登录”

    返回 (假)

.如果真结束

.如果真 (倒找文本 (temp, “成功”, , 假) ≠ -1)

    编辑框3.内容 = 文本_取出中间文本 (temp, #链接头, #链接尾, , )

    编辑框6.加入文本 (文本_取出中间文本 (temp, #链接头, #链接尾, , ) + #换行符)

    帖子链接 = 文本_取出中间文本 (temp, #链接头, #链接尾, , )

    来源 = 文本_取出中间文本 (temp, #来源头, #来源尾, , )

    调试输出 (帖子链接, 来源)

    返回 (真)

.如果真结束

返回 (假)


.子程序 _按钮1_被单击

.局部变量 结果, 逻辑型

.局部变量 文案, 文本型

.局部变量 网址, 文本型

.局部变量 json, 类_json

.局部变量 cookie, 文本型


cookie = 获取cookie (编辑框2.内容)

.判断循环首 (真)

    .如果真 (结果 = 真)

        跳出循环 ()

    .如果真结束

    .如果真 (异常 = “系统繁忙”)

        跳出循环 ()

    .如果真结束

    网址 = 编码_utf8到gb2312 (网页_访问S (“http://www.iisanye.com/”, , , , , , , , , , , , , , , , , , , , ))

    json.解析 (网址, , )

    文案 = 编辑框1.内容

    .如果真 (文案 = “”)

        文案 = json.取通用属性 (“text”, )

    .如果真结束

    结果 = 发微博 (cookie, , 文案, )

    延迟 (2000)

.判断循环尾 ()

.如果真 (异常 = “系统繁忙”)

    异常 = “”

    信息框 (“系统繁忙”, 0, , )

.如果真结束



.子程序 _按钮2_被单击


打开指定网址 (编辑框3.内容)


.子程序 获取cookie, 文本型, , 本命令由【精易网页调试助手】生成,请配合精易模块使用。

.参数 SUB, 文本型

.局部变量 局_网址, 文本型

.局部变量 局_方式, 整数型

.局部变量 局_提交cookie, 文本型

.局部变量 局_提交协议头, 文本型

.局部变量 局_结果, 字节集

.局部变量 局_返回, 文本型

.局部变量 返回cookie, 文本型


' https://weibo.com/

局_网址 = “https://weibo.com/”

局_方式 = 0

局_提交cookie = SUB

局_提交协议头 = “User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.87 Safari/537.36”

局_结果 = 网页_访问_对象 (局_网址, 局_方式, , 局_提交cookie, 返回cookie, , 局_提交协议头, , , , , , , , , , , , )

局_返回 = 到文本 (编码_编码转换对象 (局_结果, , , ))

' 调试输出 (返回cookie)

返回 (返回cookie)

211307hkk0pf00lmeg32lp.png

@GT白嫖怪

文件下载
资源名称:微博发博发帖例子


来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网⑤群:21414575

已有2位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网⑤群:三叶资源网⑤群

网站分类
随机tag
截图模块源码多页面浏览器淘宝宝贝列表分页源码按键精灵安卓版4G移动通信技术权威指南永辉生活API实例源码链接解析MYSQL数据库GDIPlusIWebbrowser2ECC模块源码注册表操作喊麦smartQQex_ui界面支持库svg图片转换CreateMutexA沃钱包网页登录API
最新评论